Overview

With Skydio 3D ScanTM your drone uses an AI-driven workflow to autonomously plan a path which captures all surfaces of the area or structure being scanned.

To create 3D reconstructions, you must upload your scan images to a third party photogrammetry provider.

In this article, we’ll cover best practices for creating 3D reconstructions, as well as introductory instructions for a few photogrammetry services.

To create a 3D reconstruction:

 

Step 1 - Capture images with Skydio 3D Scan

 

CS_3DS_S2_flying.gif

Step 2 - Upload images to 3rd party photogrammetry provider

 

 

dronedeploylogo.png

 

BentleyLOGO_RGB_no-tag.png

 

realitycapture_logo_colour.png

 

pix4dmapper_logo.png

In-Depth

Photogrammetry and Skydio 3D Scan overview:

What is photogrammetry? 
Overlap and Sidelap
Distance to Surface and Ground Sample Distance (GSD)
Types of reconstruction outputs
Environmental factors

Third-party photogrammetry providers:
DroneDeploy
Bentley ContextCapture
Pix4Dmapper
Capturing Reality's RealityCapture

What is photogrammetry? 

Photogrammetry is most commonly used in surveying and mapping and refers to the process of using photos to assist with measurement and the creation of 3D renderings.The camera captures the three dimensional world as a two dimensional graphic, and photogrammetry is the process of rebuilding this lost third dimension via software. Photogrammetry software extracts metadata from photographs to create topographic maps or models.

Overlap and Sidelap

In photogrammetry, overlap is the amount by which one photo includes the area covered by another photo; or, the overlap between photos on a path. Sidelap refers to the overlapping areas between photos on adjacent flight paths. Both overlap and sidelap are measured in percentages.

CS_3DS_overlap_sidelap.gif

Overlap and sidelap are important for creating 3D reconstructions because they provide multiple views of the area or structure along the flightpath.

Tips and best practices

For complex scenes, higher overlap and sidelap should be used if your intention is to create a 3D model, while lower overlap is suitable for inspection purposes. We recommend a 70-80% overlap and sidelap. The more complex the scene, the more overlap and sidelap is required for successful reconstruction.

Read 3D Scan Settings Overview for product-specific GSD tables and example use-cases. You can also find these tables in the 3D Scan Operator Manuals.

For more use-case examples, check out our eBook series, Enterprise Drone Inspection: Picking the Right Platform.

Increasing these percentages leads to longer scan times and an increased number of photos but more detailed reconstructions.

Distance to Surface and Ground Sample Distance (GSD)

The Distance to Surface determines how close your drone will fly to the structure or area being scanned. Adjust this during the Review Settings step of your scan setup. 

CS_3DS_3DCap_UI_edit_settings.jpg

Smaller distance to surface (closer) means an increase in total scan time but more photos taken and higher resolution. The Distance to Surface corresponds directly to Ground Sample Distance (GSD), which is a metric designed around capturing data from high altitudes. The GSD is a measure of the dimension of each pixel in a photograph on the physical surface being imaged. It indicates the most precise level of detail that can be detected in the model.

For example, a one-millimeter GSD would suggest that the distance of the two consecutive pixel centers in the photo reflects one millimeter on the ground.

Tips and best practices

When you want greater detail - or higher resolution - in your scan photos, decrease the GSD value. For example, if your goal is to capture a crack in a bridge and later create a 3D model using a third-party photogrammetry software, try setting a 1 mm GSD with 80% overlap and 80% sidelap.

The GSD value varies depending on your use-case, and the minimum and maximum surface distances vary depending on the type of drone you have.

Read 3D Scan Settings Overview for product-specific GSD tables and example use-cases. You can also find these tables in the 3D Scan Operator Manuals.

For more use-case examples, check out our eBook series, Enterprise Drone Inspection: Picking the Right Platform.

Types of reconstruction outputs

Point Cloud

A point cloud is an output made from photographs which consists of individual data points that are plotted in a 3D space. There are usually a large number of points, with each point including data such as RGB color values and georeferenced information. Altogether, these points create a 3D structure. Point clouds are used in the creation of mesh models.

Mesh

A mesh is the structural build of a model. The faces and edges are represented by converting the points in a point cloud into triangles and polygons and connecting them at their sides and vertices to define the 3D shape.

Orthomosaic
Orthomosaics are maps created from aerial photos that have been stitched together and corrected for camera tilt, lens distortion and perspective. They are most often used for inspecting or monitoring large areas of land.

Environmental Factors

Skydio 2 navigates using 45 megapixels of visual sensing from six 200 degree color cameras, building a 3D map of its surroundings that includes trees, people, buildings and more. Since it needs to see clearly to navigate past these obstacles effectively, Skydio can only fly in normal daylight conditions. Keep in mind, Skydio is not weatherproof. Its advanced computer vision won’t work at night or in other low-light conditions. The Skydio app will warn you of low-light conditions and may suggest you land if there isn’t enough light to fly safely. Read Where can I fly my Skydio 2? for more detailed information.

A variety of factors contribute to successful 3D reconstructions. Before scanning, consider environmental factors such as the amount of direct sunlight or cloud coverage that day. In general, it is best to complete your data collection in one session, as opposed to scanning over multiple days or even weeks.

Avoid scanning structures or areas that are surrounded by reflective surfaces, such as bodies of water. Smooth and reflective surfaces make it more difficult to gauge different depths around the structure.

Tips and best practices

It is beneficial to review and occasionally remove some of your scan photos before starting the reconstruction process. For example, if you have scanned a tower and there are one or more photos where the tower is not the main focus of the photo or off-center, consider removing that photo from your dataset.

Remove images that contain:

  • Too much sky
  • Wide, open, and featureless backgrounds
  • Smooth surfaces
  • Bodies of water

Third-party Photogrammetry 

The following steps are focused on the process around creating reconstructions from 3D Captures. Some settings listed may not be optimal for 2D or 2D GPS Captures.

CS_Note_callout-icon.jpg Skydio does not provide photogrammetry licenses. You must obtain licenses for any third party photogrammetry softwares independently from Skydio. Questions? Contact us.

DroneDeploy

Skydio and DroneDeploy have partnered to offer preferred processing of Skydio 3D Scans. By processing with DroneDeploy your 3D Scans will be automatically cropped to the boundary of your original scan polygon and will use a specialized processing mode for a polished deliverable.

To start processing a reconstruction with DroneDeploy, follow these steps:

Step 1 - Start new project

Login to DroneDeploy and navigate to your dashboard.

Open an existing Project if you have one, or select the blue + Project button to start a new project.

DroneDeploy1.PNG

Step 2 - Select images for upload

Navigate to the Upload tab within your Project on DroneDeploy Web. For 2D/3D Scans you should select Map or Model.

Select the JPG images you’d like to upload.

You can optionally rename the map.

Read How to access 3D Scan data for more information on how to retrieve your scan photos.

DroneDeploy2.PNG

DroneDeploy3.PNG

DroneDeploy4.PNG

Step 3 - Upload images

In this step, you have the option to adjust the scan location on the map and review, remove, or add images before you begin uploading.

If your account is permitted to do so, you have the option to add Ground Control Points on your map. Visit the DroneDeploy support website for more information about Ground Control Points.

Once you’re satisfied with your settings, select Upload Images.

A processing estimate is available at time of upload. You will receive an email once your photos have finished processing.

DroneDeploy5.5.PNG

DroneDeploy5.PNG

Step 4 - View your model

After your photos have uploaded and processed, navigate to the Model button at the bottom center of your screen. Here you can view the reconstructed model of the scene or structure you scanned.

Use the Inspect button to view your model from the camera point of view.

DroneDeploy6.PNG

DroneDeploy7.PNG

DroneDeploy8.PNG

Inspect view

Step 5 - Analyze

DroneDeploy offers a range of 2D/3D tools to analyze, including true 3D measurements and annotations. Inspections/issues can be synced directly to other third-party software you use.

You may also export various formats of your processed dataset to bring the data into nearly any system you require.

 
CS_Info_callout_icon.jpg Check out DroneDeploy Academy or their article How to Process Datasets for more in-depth videos and tips.

DroneDeploy tips and best practices

If you are flying using DroneDeploy you must exit 3D Scan to regain access to Flight Skills. To exit, first land the drone. Navigate back to the Device Settings Menu and change the Vehicle Mode to Skills.

Bentley ContextCapture

The following steps were completed on ContextCapture Version 10.18.00.270.

To start processing a reconstruction with Bentley ContextCapture, follow these steps:

CS_Note_callout-icon.jpg You must have a Windows or Linux device to use Bentley ContextCapture as it is not available on Mac OS. Review the ContextCapture Hardware Recommendations to ensure your machine is powerful enough to process reconstructions.

Step 1 - Download Bentley ContextCapture

Login to your account and ensure you have Bentley ContextCapture downloaded.

CS_3DS_media_UI_ContextCaptureMaster_start_project0.PNG

Step 2 - Start the ContextCapture Engine

After installing ContextCapture, open the ContextCapture Engine before starting your project.

CS_3DS_media_UI_ContextCaptureMaster_start_project0.1.PNG

Step 3 - Open ContextCapture Master

Select New project and name your project.

CS_3DS_media_UI_ContextCaptureMaster_start_project1.PNG

CS_3DS_media_UI_ContextCaptureMaster_start_project2.PNG

Step 4 - Upload your photos

Locate the gray Photos tab in the middle screen and select Add photos to upload your scan photos.

Read How to access 3D Scan data for more information on how to retrieve your scan photos.

Your photos will show up as one photogroup, which means they are assumed to have the same calibration. In the 3D View tab you can spot check the initial positions as reported by the photo EXIF metadata.

At the bottom of your screen, ensure the height reference is set to sea level.

CS_3DS_media_UI_ContextCaptureMaster_start_project3.PNG

Bentley1.PNG

Bentley2.PNG

Step 5 - Aerotriangulation (photo alignment)

Navigate to the General tab. On the right of the screen, select the button that says Submit aerotriangulation > Process with ContextCapture Engine.

Specify your aerotriangulation settings. We suggest checking the box to enable Photo positioning metadata. Leave the other settings as default.

You may also enable Use pose metadata for SfM.cfg which will take advantage of the position and rotation of your scan images and provide more accurate results.

Select Submit when you are satisfied with your settings and wait as aerotriangulation processes.

CS_3DS_media_UI_ContextCaptureMaster_start_project5.PNG

Bentley3.PNG

Step 6 - Review the results

The General tab will notify you if some photos failed. You can review failed photos by selecting View acquisition report.

In the 3D View tab you can view the aligned poses and keypoint surface patches. There are also visualizations that outline coverage and resolution on the left side of your screen under the chart icon.

CS_3DS_media_UI_ContextCaptureMaster_start_project9.PNG

 

Step 7 - Begin reconstruction

On the General tab, select New reconstruction > 3D Reconstruction in the bottom right.

Navigate to the Spatial framework tab. On the right of the screen you will see a preview of the reconstruction.

In the toolbar at the top, select the box with a pencil in it. Here you can adjust the faces of the reconstruction volume with the left mouse button.

By default, it will be much larger than desired. Repeatedly close in the faces, rotate, and zoom in until you have a tight volume around the photo locations that roughly corresponds to the scan volume set in flight.

This is an important step as it will result in a cleaner model and greatly reduce the runtime and memory requirements.

We suggest leaving the Processing Settings set to defaults.

When you are ready to begin, navigate back to the General tab and click Submit new production > Process with ContextCapture Engine.

With ContextCapture, a production is the final end asset you want to create which can be an OBJ mesh, point cloud, or orthomosaic.

CS_3DS_media_UI_ContextCaptureMaster_start_project11.PNG

Bentley5.PNG

Bentley5.5.PNG

Adjusted bounds

Bentley6.PNG

Step 8 - Wait for the production to finish processing

It is normal for this process to take a long time, especially when compared to the aerotriangulation step.

Bentley7.PNG

Step 9 - View your model

After your production has finished processing, you can view your model in the 3D View tab.

 
CS_Info_callout_icon.jpg Check out Bentley Education and Bentley Communities for more in-depth videos and tips.

Bentley ContextCapture tips and best practices

If you notice failures in your model, try enabling the Structured Aerial Dataset setting during the aerotriangulation step.

Pix4Dmapper

The following steps were completed on PixDmapper Version 4.6.4.

To start processing a reconstruction with Pix4D, follow these steps:

CS_Note_callout-icon.jpg You must have a Windows or Linux device to use Pix4D as it is not available on Mac OS. Review the Pix4D Computer Requirements to ensure your machine is powerful enough to process reconstructions.

Step 1 - Ensure you have downloaded the Pix4Dmapper

In order to begin processing photos, you must use the Pix4Dmapper. Download and follow the installation steps to get started.

CS_3DS_media_UI_Pix4Dmapper_download1.PNG

Step 2 - Start a new project

Launch Pix4Dmapper and select New Project.

Name your project and specify where you would like it to be saved. Select Next when you’re ready to move on.

CS_3DS_media_UI_pix4dmapper_new_project.PNG

CS_3DS_media_UI_pix4dmapper_new_project1.PNG

Step 3 - Upload images

Upload the JPG files of your scan.

Read How to access 3D Scan data for more information on how to retrieve your scan photos.

After uploading, the geotag information from the scan photos will automatically load and you will have the option to adjust the image property and the output coordinate system settings.

CS_Note_callout-icon.jpg Skydio X2 Color / Thermal users: 

During this step you must edit the Selected Camera Model setting to ensure Pix4Dmapper recognizes the correct camera focal length. Select Edit > Estimate from EXIF. 

CS_3DS_media_UI_pix4dmapper_new_project2.PNG

CS_3DS_media_UI_pix4dmapper_new_project3.PNG

CS_3DS_media_UI_pix4dmapper_new_project4.PNG

CS_3DS_media_UI_pix4dmapper_new_project5.PNG

Step 4 - Choose your template

Select 3D Models if you are processing a 3D Capture.

Leave “Start Processing Now” at the bottom right of the screen unchecked. Select Finish.

CS_3DS_media_UI_pix4dmapper_new_project6.PNG

CS_3DS_media_UI_pix4dmapper_new_project7.PNG

Step 5 - Choose settings to process photos

Your images will automatically load into the map.

In the bottom left of your screen, click the settings gear that says, Processing Options.

Ensure that Initial Processing and Point Cloud and Mesh are selected. Click OK.

In the bottom left, check Advanced. Two more setting tabs will appear at the top. Select Matching. Under Matching Image Pairs, ensure Free Flight or Terrestrial is selected. Check the box that says Use Geometrically Verified Matching under Matching Strategy.  

Once you have finalized the settings and template, select Start in the bottom left and wait as Pix4Dmapper processes your images.

You will see red dots that represent your scan capture points. The dots will change from red to green as the images are processed.

Pix4Dmapper will display a Quality Report of your model. This includes information such as:

  • A summary of the project
  • Quality checks for images, camera optimization, matching, and georeferencing
  • Calibration details
  • Geolocation details

Pix1.PNG

Pix2.PNG

Pix5.PNG

Pix3.PNG

Pix4.PNG

Step 6 - View the model

Click anywhere on the structure to view all photos containing that point.

If you’d like to view the model without the Calibrated Cameras view, navigate to the left sidebar and uncheck Cameras under Layers.

Pix7.PNG

Pix8.PNG

CS_Info_callout_icon.jpg

Check out Pix4D documentation and video tutorials for more in-depth directions and tips.

CS_Note_callout-icon.jpg

Skydio and Pix4D are actively working together to improve reconstruction results.

Capturing Reality’s RealityCapture

The following steps were completed on RealityCapture 1.2 Tarasque.

To start processing a reconstruction with Capturing Reality’s RealityCapture, follow these steps:

CS_Note_callout-icon.jpg

You must have a Windows or Linux device to use RealityCapture as it is not available on Mac OS. Review the RealityCapture OS and hardware requirements to ensure your machine is powerful enough to process reconstructions.

Step 1 - Download RealityCapture

Login to your account, download RealityCapture and follow the necessary steps for acquiring a license.

CS_3DS_media_UI_RealityCapture_start_project0.PNG

Step 2 - Upload your images

After opening RealityCapture, navigate to the top ribbon and find the Workflow tab. Within this tab, you’ll see a section labeled 1. Add Imagery. Choose one of the following ways to add your photos:

  • By clicking Inputs under the Workflow tab to add one or more images
  • By clicking Folder under the Workflow tab to add photos from a folder
  • By dragging and dropping from your device into RealityCapture

Read How to access 3D Scan data for more information on how to retrieve your scan photos.

You can change your window views by selecting one of the icons at the top of your screen. Alternatively, change views by navigating to Workflow > Application > Layout. Learn more about the RealityCapture interface here.

CS_3DS_media_UI_RealityCapture_start_project1.PNG

CS_3DS_media_UI_RealityCapture_start_project2.PNG

unnamed.png

CS_Note_callout-icon.jpg We recommend following RealityCapture’s built-in, step-by-step tutorial to become more familiar with their process.

Step 3 - Align images

Under the Workflow tab, find the section labeled 2. Process and click Align Images.

Wait as this step completes. After your photos have aligned, you will see a basic point cloud of your data with calculated camera positions.

RealityCapture1.5.PNG

CS_3DS_media_UI_RealityCapture_start_project3.PNG

CS_3DS_media_UI_RealityCapture_start_project4.PNG

CS_3DS_media_UI_RealityCapture_start_project5.PNG

Step 4 - Define reconstruction region

You may notice excess data in your point cloud. Remove it by cropping the areas outside of your reconstruction region. Move the bounds to fit your area or structure.

To do so, click on Scene 3D at the top of your screen and find Set Reconstruction Region at the far left. To manually drag the bounds, click on the gray box and drag the colored dots to your desired locations.

CS_3DS_media_UI_RealityCapture_start_project6.PNG

CS_3DS_media_UI_RealityCapture_start_project6.1.PNG

CS_3DS_media_UI_RealityCapture_start_project7.PNGCS_3DS_media_UI_RealityCapture_start_project7.5.PNG

Step 5 - Begin reconstruction
Navigate back to the Workflow tab. Find the section titled 2. Process and click Calculate Model to show a drop-down menu with processing quality options.

You may also navigate to the Mesh Model tab and select Create Model.

Choose from Normal Detail or High Detail to create your reconstruction.

When you’re ready to begin building your model, click Start.

CS_3DS_media_UI_RealityCapture_start_project8.PNG

CS_3DS_media_UI_RealityCapture_start_project9.PNG

Step 6 - View model

Check out Capturing Reality tutorials for more detailed information on tools for filtering unwanted parts of your model. 

 
CS_Info_callout_icon.jpg Check out Capturing Reality tutorials for more in-depth videos and tips.

Explore More

Explore related articles for additional information:

Read 3D Scan Settings Overview for product-specific GSD tables and example use-cases. You can also find these tables in the 3D Scan Operator Manuals.

For more use-case examples, check out our eBook series, Enterprise Drone Inspection: Picking the Right Platform.

3D Scan Operator Manuals

How to access 3D Scan data

 

If you have questions or need additional support—feel free to reach out! Skydio Support

 

 

 © 2021 Skydio, Inc. All rights reserved A0102

 

Was this article helpful?